Problem with Samba Please help

elik at elik at
Wed Sep 20 18:02:38 GMT 2000


1) We are using Samba 2.0.4 with a unix file 
server and we started using Windows 2000. 
However we are having problems with win2k, it 
does not let you change a directory name after 
creating the directory. We updated Samba to ver. 
2.0.7 on a test machine and it solved the 
problem partially. There is however still a 
problem, after being logged in for a few hours, 
when you try to change the directory name it 
changes the name, but it does not refresh the 
the screen, only after about 50 seconds (or by 
presing F5). Is there any setting or parameter 
to chnage in smb.conf or some place else to 
solve this problem?

2) We also use Windows 95 and Windows 98 
machines, and when using Excel with samba 2.0.4, 
many employees share the same files by opening 
it as read only. The problem is that sometimes 
Excel will still let one employee open the Excel 
file in read and write mode, even though another 
employee is already in the file from before. 
This usually happens after the first person to 
access the file was in it for more than one day. 
When the first person that accessed the file 
will try to save it, he will get an error and 
will not be able to save. 
The user will get a message that the file is 
being saved for someting similar to a Hex name 
(like 23ef454d). To my understanding it looks 
like samba is losing the connection after a 
certain amount of time. My main question is, if 
by updating to samba version 2.0.7 will these 
problems be solved, or is it a wrong 

We used this following settings in smb.conf in 
the samba ver. 2.0.4 

locking = yes 
strict locking = yes 
kernel oplocks = yes

Please help us solve this problem, if you need 
any more info to find a solution, please let me 
know. (Even if you have a temporary fix please 
let me know.)

Thank You

Best Regards;

Eli Kleinman
At B&H Photo 

More information about the samba-technical mailing list