nmblookup won't query node status

Herb Lewis herb at chomps.engr.sgi.com
Wed Nov 8 16:02:48 GMT 2000

Mike Brodbelt wrote:
> Hi,
> I'm attempting to use nmblookup from within a script to find which NT
> user is logged into a certain machine. The script will have the IP
> address of the machine in question, so the command I've tried is:-
> $ nmblookup -A
> Looking up status of
> This returns nothing else. Similarly, the -S option fails:-
> $ nmblookup -S arcturus
> querying arcturus on
> arcturus<00>
> Looking up status of
> AFAIK, both these used to work (but haven't for some time - I've asked
> related questions on the main Samba list), and I've no idea why. Is this
> a bug, or am I just being stupid? Clients in question are NTSP6.
> TIA,
> Mike.

These work for me. You didn't say what OS or what version of Samba
you were using. Have you tried rebooting the client and then running
nmblookup? I have found that sometimes the client will stop 
responding to nmblookup and after a reboot works again.
Herb Lewis                               Silicon Graphics 
Networking Engineer                      1600 Amphitheatre Pkwy MS-510
Strategic Software Organization          Mountain View, CA  94043-1351
herb at sgi.com                             Tel: 650-933-2177
http://www.sgi.com                       Fax: 650-932-2177          

More information about the samba-technical mailing list