Urban Widmark urban at
Thu Jul 27 22:55:52 GMT 2000

On Thu, 27 Jul 2000, Neil Hoggarth wrote:

> I don't know, but (speaking as an outsider who has tried to contribute
> via samba-patches[1]) it appears to have been just setup and left to
> rot.
> This may be an inaccurate impression. It is quite possible that someone
> is reading the submissions and doing something with them, and it's not

Browsing through a few shows that some have received replies, so all/most
of them have probably been read. Some should have been moved out of
incoming, at least one into accepted.

> The samba(7) page distributed with v2.0.7 suggests that patches and bug
> reports ought to be sent to the samba at list, rather than
> mentioning samba-patches. If the samba-patches system isn't being used
> and maintained then it seems to me that it ought to be killed off. I

Yes, that is a conflict.

Sending to samba-patches makes it hard for it to be lost (assuming someone
goes through the backlog every now and then) while sending it to samba may
make it disappear unseen by the right people into some archive.

OTOH, sending it to samba exposes it to many more eyes. I doubt many
outside the core team goes through samba-patches looking for interesting

Maybe you are supposed to send it to both places?

I have a pair of fixes for some minor smbmount things (no, not the
"disconnect smbmount from the kernel sources patch", btw I am getting more
support for that on linux-kernel in the "RLIM_INFINITY" thread as I write
this) that I'm almost ready to send somewhere, but I'm not sure who wants

samba-patches? samba? both? either?


Return-Path: <davec at>
Delivered-To: samba-technical at
Received: from ( [])
	by (Postfix) with ESMTP id 758ED139FB
	for <samba-technical at>; Thu, 27 Jul 2000 12:51:50 -0700 (PDT)
Received: from ( [])
	by (8.9.3/8.9.3/Debian 8.9.3-21) with ESMTP id FAA12048
	for <samba-technical at>; Fri, 28 Jul 2000 05:51:33 +1000
Received: from ([]:58525 "EHLO") by with ESMTP id <S27329039AbQG0TtH>;
	Fri, 28 Jul 2000 05:49:07 +1000
Received: Received: by with SMTP id TAA58904
 	       ; Thu, 27 Jul 2000 19:45:04 GMT
From: davec at
Received: by COLUMBIAENERGYGROUP.COM (Soft-Switch LMS 3.2) with snapi
          via NOTES id 0056990013501338; Thu, 27 Jul 2000 15:43:04 -0400
To: "        -         *samba-technical at": ;
Cc: " - *Stewart, Amber" <astewart at>,
	" - *Noon, Nathan" <nnoon at>,
	" - *Damen_Rund at":;;" - *nkidd at":;" - *bkeats at":;;
Subject: Re: samba-technical digest, Vol 1 #21 - 19 msgs
Message-ID: <0056990013501338000002L982*@MHS>
Date:   Thu, 27 Jul 2000 15:43:04 -0400
MIME-Version: 1.0
Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline
Sender: samba-technical-admin at
Errors-To: samba-technical-admin at
X-BeenThere: samba-technical at
X-Mailman-Version: 2.0beta2
Precedence: bulk
List-Id: Discussions on Samba internals <>


What is probably happening when you telnet in is your bash profile sets
a path to your useraccount that is different from the path set when you
are root.

A couple ways to fix this are:

When you su to root, type
source ~/.bash_profile

or copy the .bash_profile from your ~root to ~my_account

or edit the the /etc/profile to include the location of useradd, which is
usually in /usr/sbin

Hope that helps,


> On Fri, 21 Jul 2000, Damen Rund wrote:
> > Hello,
> >
> > once again I'm stumped.  I telnet into my Linux box as myself then run a
> > su command to login as root, then I want to add a user so I run the
> > useradd command and get the response "bash: useradd: command not found"
> >
> > however if I goto the Linux box and log in as root I can use the useradd
> > command with no problem.
> >
> > THANK YOU :-)
> >
> > Damen C. Rund
> > Computer Service Technician

More information about the samba-technical mailing list