Joining Samba domains, and .mac files

Simon Hyde shyde at
Sun Jan 9 17:04:28 GMT 2000

I apologise if this is a simple query answered somewhere in the docs, but
I've tried quite hard and can't for the life of me find it. I'm afraid
i've not had time over the 1 1/2 years to keep track of the samba
development and am finding i now know very little about the current CVS
version of Samba.

Basically, I've just switched from a version of samba from the CVS HEAD in
april-ish, to the current SAMBA_TNG release, and now cannot get my WinNT
syustems to join a domain after I've run smbpasswd -a -m
<machine>$. Digging through my log files, i'm guessing this might have
something to do with the following which comes up every time i try to add
the machine:
[2000/01/09 16:36:15, 0] passdb/smbpassfile.c:trust_password_lock(78)
  trust_password_lock: cannot open file /usr/local/samba/private/RAWNET.RAW.mac
- Error was No such file or directory.
[2000/01/09 16:36:15, 0] passdb/smbpassfile.c:trust_get_passwd(239)
  trust_get_passwd: unable to open the trust account password file for trust RAW
 in domain RAWNET.

The server name is RAW, and the domain name is RAWNET

I tried as was suggested on samba-cvs to run smbpasswd -j raw$, however
this complains about not being able to add to the domain because it is the
PDC (I did however try running smbpasswd -a -m raw$ which seemed to work,
adding the usual trust account line to smbpasswd)

Do I now have to use the "Create machine account" to add a machine to a
domain, if so what account and password do i use?

Simon Hyde
IT Manager
RaW - Radio Warwick
I.T.Manager at

More information about the samba-technical mailing list