cvs SAMBA_2_0: some problems

Giulio Orsero giulioo at
Wed Jan 5 09:06:31 GMT 2000

These are some of the problems I had with 2.0.6 and that are still in
SAMBA_2_0 (as of 4 Jan 1999).
I installed SAMBA_2_0 on linux 2.0.33.

=== 1) smbclient mputting
When mputting on a win9x there are 2 problems:
a) if you mput an empty file, the file is transferred but samba logs an
error, which is not the case
b) if you mput an empty dir, the dir is not shown in the mput output, I
think it should be shown as it is actually transferred.

$ ls -lRF
total 2
drwxrwxr-x   2 go       cdi          1024 Jan  5 09:35 d1/
drwxrwxr-x   2 go       cdi          1024 Jan  5 09:35 d2/
total 1
-rw-rw-r--   1 go       cdi             0 Jan  5 09:35 f1
-rw-rw-r--   1 go       cdi             5 Jan  5 09:35 f2
total 0

smb: \> recurse
directory recursion is now on
smb: \> prompt
prompting is now off
smb: \> mput *
putting file d1/f1 as \d1\f1 Error reading local file
(0 kb/s) (average 0 kb/s)
putting file d1/f2 as \d1\f2 (0.0567768 kb/s) (average 0.0339084 kb/s)
smb: \>

=== 2) smbclient: renaming directories
smbclient1.9.18p10 can "rename" dirs on a win98 share, smbclient2.0.6
and SAMBA_2_0  cannot do it:
ERRDOS - ERRbadfile (File not found.) renaming files

=== 3) new problem of SAMBA_2_0
if you smbclient from samba2.0.6 or 1.9.18 to SAMBA_2_0, and do "ls",
you get the list of files and:
- from 2.0.6 "Error in dskattr: code 0" at the end of the list
- from 1.9.18 "Broken pipe" at the end of the list

=== 4) veto files (2.0.6 is the same of SAMBA_2_0)
Since "hide  dot files" relies on clients settings, I want to use "veto
files" to hide file beginning with a dot.

The man page for "veto files" says:
 '*' and '?' can be used to specify multiple files or directories a
in DOS wildcards.
I tried
veto files = /.*/ but this hide all files not just the ones beginning
with a dot.

so I tried  /.*.*/ -> same as above

then /\.*/ -> doesn't hide anything

=== 5) log/hup
samba-2.0.6 still had the hup/log problem, and SAMBA_2_0 too:
connections that are already active keep logging to the old logs.
With samba-2.0.6 (on rh60) I have logrotate that rotates the logs every
night and then gzips the files: the morning after the samba logs are 0
sized and have the timestamp of the time logrotate rotated the logs,
samba stops logging till restart.

giulioo at

More information about the samba-technical mailing list