Funnies with Win2K professional RC2 install

Richard Sharpe sharpe at
Mon Nov 8 11:43:51 GMT 1999


I admit it, I am thick :-)  However, my excuse is that Win2K has at least
one place left were a reboot is needed after you change things :-)

I said:

>well, this is most confusing.
>I installed Win2K Professional RC2 on a machine, put it into a Workgroup and 
>then tried to browse the network.  It showed me the workgroup, Sambanet, but 
>would only show me the Win2000 machine in that network.  
>I could search for other machines, and it would find my Samba server, but 
>would not allow me to browse the machine.  I have an ethereal trace of the 
>Win2K machine connecting and then disconnecting as soon as it got the
>This went on for about a day as I intermittently looked at it.
>I then changed my Samba server to using encrypted passwords, and was able to 
>browse the network, although I saw some delays that I have not yet check out.
>I then switched back to non-encrypted passwords, and now, magically, I can 
>browse the whole network and can browse servers etc. I have rebooted to
see if 
>there is any memory kept unless you reboot. 
>Now, I would put this down to a one-off glitch, but since I am writing a 
>chapter about Win2k and Samba for a book on Samba, this has potential for
>of nastyness.  If people encounter the same problems I did, then they are
>likely to believe the book.
>So, what I am interested in knowing is: Has anyone else seen anything like 
>this with Win2K Rc2?  Does anyone know of any registry settings that might 
>affect the browsing behaviour etc.

Problem solved.  You have to reboot after changing that registry setting
before it takes effect ...

Richard Sharpe, sharpe at, Master Linux Administrator :-),
Samba (Team member,, Ethereal (Team member,
Co-author, SAMS Teach Yourself Samba in 24 Hours
Author: First Australian 5-day, intensive, hands-on Linux SysAdmin course

More information about the samba-technical mailing list