oplock errors

Michael Ju. Tokarev mjt at tls.msk.ru
Fri Nov 5 14:48:09 GMT 1999

David Collier-Brown wrote:
> Michael Ju. Tokarev wrote:
> | Samba has a bug (stilllll unconfirmed by samba team) on Solaris
> | (Or maybe Solaris has a bug). Do not use oplocks on Solaris
> | until this issue will be resolved.  (Maybe samba team need solaris
> | machine?)
>         Got lots. Can't reproduce the bug for the team to swat!
>         If you can reproduce the bug, can you help with debug
>         logs and truss/sotruss output?

This bug is a bit "strange" (if one can say so). As I see here,
not all Solarises have such problem. But if you look to message
archives, you can see that almost all questions about oplock
breaks was sent by Solaris users (don's know if users with other
machines affected also). I was not shure only if this present on
all solarises, and now I see that it isn't. My "reproduce" is
trivial -- set "oplocks = yes" and things does not worked anymore,
and hardware, client software etc does not matter here.
Just make two opens of the same file -- second one will get delay
about a minute, and log.smb will show that "well-known" oplock_break
problem, and finally "restarting this smbd". Oplocks was introduced
in 1.9.something, and that version was worked fine; but starting from
first public beta (not alpha) of 2.0 oplocks was not work (for me ;).
Some time ago I reported this to samba-bugs, but got "not reproduceable"
responce (and got very interesting reply from samba-bugs system
that tell me that this problem is hardware related).
I'm not a newbie in computers, but I does not know anything about
smb protocols (except of rfc1000/10001), so I don't know what I can
do to produce useful trace files (gigantic trace/log with full session
details will not be very useful;). Now I have several machines with
very different hardware (but all intel-based), and only one with solaris
(linux is on others, and so I can use tcpdump, as truss does not understand
smb protocol, and I was not very interested in compiling tcpdump on

Well, today (I hope) I'll try to produce some traces/logs (is level 10 enouth?),
and also try to see 2.1.6pre3, as suggested by Jeremy.

P.S. My exact environment seemed to be very unstable regarding of this oplocks
problem (maybe betted to say that I don't know what situation caused this
problem to appear, and that situation is not shows up often). Last my attempt
to reproduce this failed (things are worked fine for some time), and my reply
to bug system (PR#19728) showed this (that was veery strange to me).
But a day after things was breaked again, and seemed to be very stable again.
Remember -- almost all questions are from solaris users...
And also sorry me -- I have very limited time to do testing, since our solaris
is a production machine, and so available for experiments only at evening/night
(whay people need to sleep sometimes!?), and I haven't ability to setup another
solaris for now (I tried this sometime ago, with the same problems with oplocks).


More information about the samba-technical mailing list