Samba 2.0 RedHat/PAM password troubles found and solved!

Dr J Pelan J.Pelan at
Wed Jan 27 23:21:08 GMT 1999

On Thu, 28 Jan 1999, Dax Kelson wrote:
> I tried upgrading from samba 1.9 to 2.0 on two seperate RedHat
> servers, and after both upgrades nobody could get authenticated.  The
> windows boxes had the registry hacks to turn off encrypted passwords,
> and I'm authenticating out of passwd+shadow.

> Samba 2.0 tries to open:
> /etc/pam.d/samba and failing (since it doesn't exist on any box I've
> ever seen)

Well done locating your problem. However for sake of completeness I'll
point out that it is on all RedHat (5.[1|2]) boxes that I've seen
by virtue of the fact that the Samba RPM has been installed, e.g.;

% rpm -q -f /etc/pam.d/samba

% cat /etc/pam.d/samba 
auth    required        /lib/security/ nullok shadow
account required        /lib/security/

Clearly if building sans RPM you'll miss out on that vital file.
Perhaps this is an answer to the question posed in pass_check.c, namely

  * Query: should we be using PAM_SILENT to shut PAM up?

John P.

More information about the samba-technical mailing list