PDC upgrade from beta4 to 2.0 failure

Andy Bakun abakun at reac.com
Thu Jan 21 17:58:18 GMT 1999

Hello all.

Last night, I tried to upgrade my PDC running samba 2.0.0-beta4 to
2.0.0-final.  It did not go well.
My network layout is as follows:

   * Samba 2.0.0-beta4 PDC.  security = user. Named Jupiter
     /etc/MACHINE.SID file contains
   * Samba 2.0.0-final Domain member. security = domain, password server =
     /etc/MACHINE.SID contains
   * 1 Windows 95 machine
   * 25 Windows NT Workstation 4.0 SP4 machines.
   * 2 Windows NT Server 4.0 SP4 machines with 'stand-alone' installation
     (that is, no PDC or BDC functionality)

Now, the upgrade of Jupiter from beta4 to 2.0.0 changed the MACHINE.SID
file from




And as such, none of my machines could login.  They got error C000019B

Marcus Graf had this problem, see the thread at
http://www.samba.org/listproc/samba-ntdom/3053.html, but it didn't seem to
ever be resolved.  I remember something about interpreting it as hex rather
than decimal.  I tried to trick it into reading it as the number it was
expecting, but this didn't work.  Does this mean that all my workstations
have to be readded to the domain when upgrading to 2.0.0-final, or is there
some other change I can make to get this to work?


More information about the samba-technical mailing list