problem with credentials

Michael Reinelt reinelt at
Wed Dec 29 20:54:01 GMT 1999

Hi there,

I'm having some problems with credentials while connectiong from a
NT4SP{5,6} Client to a samba 2.0.6 server on Linux 2.0.38

What I want:
Users have their home share, and several public shares. I'm using
security=user, encrypt passwords=yes, and no domain functionality
(workgroup only). Up to this, everything works fine (for years!).

Now I have a special share, where only special users have access to, and
only if they know a special username and password. I added this new user
to /etc/passwd and /etc/smbpasswd, and added a 'valid users=' line to
this share.

If a client tries to connect to this share, a dialog pops up. "wrong
password or unknown username for \\server\share" (I'm using the german
release of NT, so the original message is "Falsches Kennwort oder
unbekannter Benutzername"). Now I have two fields where I can enter a
username and a password. This is what I expect, and I want users to
enter the special username and the password. When I try to, I get a
error from NT "Die angegebenen Referenzen passen nicht zu einer
bestehenden Referenzmenge" (I dont't know the correct translation, but I
think it's the credentials problem.

When I remove the 'valid users'-line, it works fine. 
I tried to change the username, the share name, the user id, everything
I could think of. No change.

I used 'net use \\server\share /del' several times, doesn't help. I
rebootet NT several times, same problem.

I raised the samba debug level, but found nothing of interest in the
logfile. nothing? Wait, this one is strange: When I first access the
share (I click on it in the network neighbourhood), I see the message
"invalid username/password for share". This message is correct, because
the user cannot access the share with the username he is logged in on
the NT box. After this message appears, the "connect as.." dialog box
opens on NT. When I enter the correct username/password, nothing appears
in the samba logfile! Seems as if this error appears already on the NT
system, before it even tries to authentificate with samba!

Another strange thing: I can enter _any_ username, no matter if it
exists or not, and _any_ password, I always get the same error!

I don't understand this behaviour.

What else could I try?

thanks in advance, 

netWorks       	                                  Vox: +43 316  692396
Michael Reinelt                                   Fax: +43 316  692343
Geisslergasse 4					  GSM: +43 676 3079941
A-8045 Graz, Austria			      e-mail: reinelt at

More information about the samba-technical mailing list