file_exists() calls dos_to_unix()

Jeremy Allison jallison at cthulhu.engr.sgi.com
Mon Nov 23 21:56:40 GMT 1998


Luke Kenneth Casson Leighton wrote:
> 
> should be called unix_file_exists(), dos_file_exists() calling
> unix_file_exists().
> 

Well the unix_ bit is sort of redundent :-).

> > BTW: Have you worked out the problem with the uint32 <-> gid_t
> > issue yet in your new code in HEAD ?
> 
> what's that, then?


The following problem still exists in the HEAD branch :

Jeremy.

-------------cut here-----------------------------

Luke,

        I think there are some things broken in this latest
code.

For example - in compiling I get :

Compiling passdb/smbpassgroup.c
"passdb/smbpassgroup.c", line 139: remark(1506): implicit conversion from
          "unsigned int" to "long":  rounding, sign extension, or loss of
          accuracy may result
                                (*als_rids)[i] =
pwdb_gid_to_alias_rid((*als_rids)[i]);
                                                                       ^

"passdb/smbpassgroup.c", line 157: remark(1506): implicit conversion from
          "unsigned int" to "long":  rounding, sign extension, or loss of
          accuracy may result
                                (*grp_rids)[i] =
pwdb_gid_to_group_rid((*grp_rids)[i]);
                                                                       ^

Looking carefully at this code, pwdb_gid_to_alias_rid()
and pwdb_gid_to_group_rid() should take a UNIX gid_t
and map them into a RID. You are passing a RID to these
functions.

You are reading a list of RIDs from a group file (the note
you just sent out says it should be names, not numbers BTW),
and then passing them through a "convert from gid_t to RID"
function !

This doesn't make sense.

What is this code trying to do ?
------------------------end cut-------------------
-- 
--------------------------------------------------------
Buying an operating system without source is like buying
a self-assembly Space Shuttle with no instructions.
--------------------------------------------------------


More information about the samba-technical mailing list