MAX_OPEN_FILES etc ...

Richard Sharpe sharpe at ns.aus.com
Fri Jul 31 04:54:03 GMT 1998


Hi Folks, 

following on from my earlier comments and Andrew's responses to my change
suggestions, here is what I am thinking of:

1. Create a new source file, files.c

2. Move all code that handles the Files and FileFD structures into this
source file.

3. Provide access routines that provide access to paramenters in an object
oriented manner

4. Get rid of macros from header files that access Files directly.

This has a performance implication. Now, instead of CHECK_READ accessing
Files[fnum].can_read, a function call will be made to can_read_file(fnum)
or some such function.

I think that this performance hit will be small for the improvement in the
manageability it gives us.

What I am seeking is:

a. Feedback

b. An appropriate naming convention for these.

   File_can_read(fnum)?
   File_get_max_fnum()?
   File_get_new_fnum()?
   etc ...



Regards
-------
Richard Sharpe, sharpe at ns.aus.com, NIC-Handle:RJS96
NS Computer Software and Services P/L, 
Ph: +61-8-8281-0063, FAX: +61-8-8250-2080, 
Samba, Linux, Apache, Digital UNIX, AIX, Netscape, Stronghold, C, ...


More information about the samba-technical mailing list