smbpasswd -a problem

Luke Kenneth Casson Leighton lkcl at
Wed Dec 2 22:31:24 GMT 1998

On Thu, 3 Dec 1998, Tim Winders wrote:

> Weird.  I have the HEAD branch from 20-Nov.  I just did a smbpasswd -a
> command and the user was added to the smbpasswd file but with the wrong
> unix ID.  I caught this because the user couldn't login.  Their unix uid
> was 226 but their smbpasswd uid was being assigned 291.  I removed the
> user entry in smbpasswd and tried again with the same result.  I manually
> changed the uid field in smbpasswd to 226 and they could login.  Ideas or
> should I get the latest CVS and try again?

yep.  fixed it yesterday morning.  two calls to getpwnam(), one inside the
password database API and one before it.  getpwnam() returns a static
buffer.  copied the uid and name of the first call before allowing the
pwdbAPI to proceed, problem fixed.

>  With all the recent updates, I am becoming afraid!  :-)

welcome, all brave souls.  always make a copy, first.

More information about the samba-technical mailing list