Unable to login to NT PDC from Linuxbox

Mark Cooke mark at mmebs.co.uk
Fri Jan 4 04:27:03 GMT 2002

Iam trying to setup winbindd on a linux box, so anyone who logs in can use 
their NT passwd and an account is then created on hte Linux box.

So far Ive installed Samba-2.2.2 from RedHat Rawhide.
Ive copied all the correct links across and edited my smb.conf file to 
include the following:



# Windind configuration
    winbind separator = +
    winbind cache time = 10
    template shell = /bin/false
    template homedir = /home/%D/%U
    winbind uid = 10000-20000
    winbind gid = 10000-20000

# workgroup = NT-Domain-Name or Workgroup-Name
    workgroup = MMEBS

# Security mode. Most people will want user level security. See
# security_level.txt for details.
    security = domain

# Use password server option only with security = server
# The argument list may include:
#   password server = My_PDC_Name [My_BDC_Name] [My_Next_BDC_Name]
# or to auto-locate the domain controller/s
#   password server = *
    password server = THOR

# You may wish to use password encryption. Please read
# ENCRYPTION.txt, Win95.txt and WinNT.txt in the Samba documentation.
# Do not enable this option unless you have read those documents
    encrypt passwords = yes
;   smb passwd file = /etc/samba/smbpasswd


In /etc/nsswitch.conf put the following:

passwd:     files winbind nisplus
shadow:     files winbind nisplus
group:      files winbind nisplus

Also adding the following to '/etc/pam.d/system-auth'

auth       sufficient   /lib/security/pam_winbind.so use_first_pass
after the line which reads
auth       sufficient    /lib/security/pam_unix.so likeauth nullok

then I ran:

smbpasswd -j MMEBS -r THOR -U admin
password: password

That got accepted into the domain: joined domain MMEBS
This I checked again our PDC and the linuxbox (named scaramanga) is listed 
as part of the MMEBS domain.

I then started winbindd and checked the output of 'wbinfo -t'
which ouputed: secret is o.k

so I then checked the output of  'getent passwd' and 'getent group'
which reports all hte users and groups from hte NT PDC in hte MMEBS domain 

So I then started  samba and the samba server is showing up in the MMEBS 
domain correctly, but Iam unable to log in.
so I then ran :

wbinfo -a admin+password
plaintext password authentication failed
Could not authenticate user admin+password with plaintext password
challenge/response password authentication failed
Could not authenticate user admin+password with challenge/response

and got the resonse listed above.
Ive enabled encrypted passwds in the smb.conf file, so thats o.k.

Also if I run wbinfo -m
It just takes me back to the prompt.

Could anyone possable point out where Iam going wrong please.

Thanks in advance


Mark Cooke
Internet Operations Technician
MM Group Ltd
Tel: 8141 (Internal)
Tel: (0117) 9168141 (External)
Email: mark at mmebs.co.uk

More information about the samba-ntdom mailing list