Trying to use SAMB as a PDC for WinME Roaming profiles & as print server

Peter Tunstall peter.tunstall at
Sun Nov 4 01:34:01 GMT 2001

I have scoured all the resources etc read the SAMBA project docs front to
back, used diagnosis.txt , all to no avail I can only get so far and then
no further.

At the moment I am concentrating on the roaming profile issue, I will try
printing myself later.

Can anyone help I have run out of ideas, I willing to bet the solution is
looking me in the face but I have been trying to sort this for about two
weeks now, during which I must have completely reinstalled about five times.

I can't see the wood for the trees now, and the wife is threatening divorce,
but I am not going to give up.
Any help to fix the problem or new leads would be much appreciated much

I have included below my  hardware details, smb.conf and as much other info
as possible regarding steps already taken.

First Hardware:-

2 WinME machine (PIII 450 & a P4 1.3)
1 Fresco firewall (466 Dx2)
1 P100 70Mb Ram set up as Linux box, Mandrake 8.1, setup as DNS server and
SAMBA 2.2.2 server.

My smb conf is as follows:-
# Samba config file created using SWAT
# from (
# Date: 2001/11/03 17:31:01

# Global parameters
workgroup = MSHOME
netbios name = SERVER
server string = Samba Server %v
encrypt passwords = Yes
password level = 8
username level = 8
unix password sync = Yes
log file = /var/log/samba/log.%m
max log size = 50
socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
printcap name = lpstat
domain admin group = users
logon script = %U.bat
logon path = \\%N\profile\%U
logon drive = X:
logon home = \\L%\%U\.profiles
domain logons = Yes
os level = 255
lm announce = True
lm interval = 30
preferred master = True
domain master = True
dns proxy = No
wins support = Yes
default service = homes
remote announce =

path = /data/dos/netlogon
hosts allow =

comment = Home Directories
read only = No
guest ok = Yes
browseable = No

comment = All Printers
path = /var/spool/lpd/Printer
create mask = 0700
guest ok = Yes
printable = Yes
print command = lpr-cups -P %p -o raw %s -r # using client side printer
lpq command = lpstat -o %p
lprm command = cancel %p-%j
browseable = No

comment = shared temp directory
path = /home/shared
read only = No
guest ok = Yes
delete readonly = Yes

Network setup Windose

TCP/IP IP's set 192.168.0.X
Subnet Mask

WINS disabled

DNS enabled (server) host <machine name> domain mshome

Gateway (router/firewall)

Primary Network Login Client for microsoft networks
properties NT logon set domain mshome

Progress so far:-

When I go login from Win I get a ' no server available to athenticate

In windows from network places entire network nothing showing but if I
search for server it is found and all comments etc correct, also can see
shares and the correct user home dir based on login.
ie if user1 logs in I see user1 home and so on. Good news I hope somthing is

But still I cannot get SAMBA to authenticate and download profiles etc.

Next I tried the diagnostics.

TEST 1 testparm shows no errors
Test 2 can ping OK both ways
Test 3 smbclient -L server I get a positive response no problem
Test 4 nmblookup -B server __SAMBA__ again get proper response
Test 5 nmblookup -B main '*'
querying * on
name query failed to find name *
Test 6 nmblookup -d 2
All I get is a successful response from the server itself, nothing from the
windows boxes.
Test 7 smbclient //server/tmp works fine login and get smb> prompt.
Test 8 net view from PC all i see is the PC itself nothing else.

I have also put the server in the LMhosts file on win box and still no joy.



More information about the samba-ntdom mailing list