Jose M. Sanchez opjose at ex-pressnet.com
Mon May 7 19:56:16 GMT 2001

-----Original Message-----
From: newbie-owner at linux-mandrake.com
[mailto:newbie-owner at linux-mandrake.com]On Behalf Of kaab kaoutar
Sent: Sunday, May 06, 2001 8:18 AM
To: samba-ntdom at lists.samba.org; samba at lists.samba.org
Cc: newbie at linux-mandrake.com
Subject: [newbie]

Hi !
I have a domain called EMAGIN, composed of NT workstations and an NT server
called SERVER1.In one of the NT workstations, i have also installed linux
mandrake7.2 in a partition. This machine is called kaoutar.

I've installed Samba in it, and tried to join the EMAGIN domain, letting
SERVER1 the domain contoller. I have shared a directory called KTI.

Here is my smb.conf:
        netbios name=kaoutar
        workgroup = EMAGIN
        server string = Samba %v on (%h)
  security = domain
  password server=SERVER1
  encrypt passwords = Yes
local master = no
domain controller=SERVER1
name resolve order =lmhosts wins hosts bcast
mangled names = yes

        comment = KI
        path = /var/www/html/site_kti
        writeable = no
        guest ok = Yes
        read only =yes
I have created a user account in linux and samba with the same
authentication parameters of the NT server administrator.

when i type : smbclient -U% -L LOCALHOST
I first got : unkonwn parameter encountered "domain controller"
then it gives the right results...


The %U is only valid in a Samba script, and Localhost does not define the
interface on which Samba is responding which is why you get an error


but i realized that it does not  make the right resolution for server1, so i
added the ip address of server1 to the /etc/host file then it updated the
error to:


Eh, I don't think you understand what you are trying to query.

Try smbclient -L kaoutar -U username

Remember to replace "username" with a VALID SAMBA login name.

If you get a "bad password" error then that user does not exist in Samba or
on the target machine.


and that's also what it gives when i tried to make samba server join the
EMAGIN domain, so obviously samba have not yet joined the domain.


Eh, you haven't queried any machine which is part of the domain yet!

How about trying

smbclient -L SERVER1 -U username


By the way the "/etc/lmhost" is composed of only one line:
localhost !
is it normal ?




Well, the NT workstations and server easily access the shared directory!
However, when i try to browse the network via konquekor, it fails, it keeps
asking for server1 and kaoutar authentication.


Konqueror does not browse Windows shares by itself!

opjose at ex-pressnet.com

More information about the samba-ntdom mailing list