problem saving roaming profile

Lista linux linux at
Mon May 7 17:10:31 GMT 2001

I had the same problem, but my way around ws to make the USER.DAT  a .MAN
file, then there was no problem, BTW, I only have W2K clients.

I had some problems with adding printers but it ended when the patch
between the switch and the server was changed. This clients were able to
log into the domain and surf the net, but showed problems when installing
printers and saving the roaming profile.


On Mon, 7 May 2001, Hitesh Talati wrote:

> I think, I have resolved the problem and it sure is a WIN2K problem.
> Just as I has said earlier, although we do run several samba servers in our
> domain, the PDC still is NT4. The major difference in NT and WIN2K in terms
> of storing profiles is that in NT its under WINNT\Profiles\%username% and
> under WIN2K it is under "Documents and Settings/%username%". So, when a user
> with a roaming profile logs onto an NT machine, everything works fine but
> when he logs on WIN2K terminal server, it creates his default profile under
> "D & S" folder and I think it tries to copy the profile with this new path
> back on to the shared profile path  which is actually
> \\servername\profiles\%username%. This gives a msg of access denied. (This
> is strange as the message shuold say path not found or something like that).
> I can reproduce this as many times as you want. Because this only happens if
> its a fresh install of WIN2K. This does not happen if an NT4 is upgraded to
> WIN2K as the profiles are preserved in the original location during an
> upgrade.
> The solution which has worked here for me is that instead of sharing the
> profiles folder, I went ahead and shared the user's actual folder which
> contains his profile. i.e let's say if the user's name is john, I shared the
> folder 'john' instead of \profiles which contains a folder john. So that the
> roaming profile path for john is now \\servername\john instead of
> \\servername\profiles\john. This works perfectly fine for me whether a user
> uses an NT, samba or WIN2K. I have tested this very well and the profiles
> are uploaded and downloaded with all the changes made during a session
> without giving any error messages.
> Pls let me know if any of you has a different opinion or has found anything
> else.
> rgds
> Hitesh
> -----Original Message-----
> From: Martin Thomas [mailto:mthomas at]
> Sent: Monday, May 07, 2001 10:34 AM
> To: Gerald Carter; Oliver Heering
> Cc: Hitesh Talati; samba-ntdom at
> Subject: Re: Re[2]: problem saving roaming profile
> This may be a small hint to find a solution:
> some directorys in the profile on the windows machines have the
> dos 'read only' attribute set. Samba does not map this attribute
> correct, at least here (windows 2ksp1 clients/german, samba 2.2 cvs
> from May,3 2001, linux suse 6.3 with updated kernel 2.4.4 but without
> acl-patch).
> Since samba seems to ignore the 'read only' and sets the directory mode
> to rwx insteat of r-x during profile upload to the samba server.
> Windows may be 'confused' by this, since the downloaded profile directory
> has the 'read only' attribute not set, because of the rwx mode of the
> directory
> To reproduce this:
> - login to w2k, download profile
> - open a document on a network share in word or excel, windows caches
>  the path as a shortcut in the 'network neighbourhood', in the windows
>  file-system this shortcut is a directory in the folder:
>  c:\Dokumente und Einstellungen\<username>\netzwerkumgebung\<share> auf
> <server>
>  (i try to translate: c:\Documents and settings\<username>\network
> neighbourhood\<share> on <server>)
> - this directory has the 'dos read only' attribute set, which marks the
> directory as a shortcut in this
>  case (the attribute might have another meaning in other folders)
> - logoff from the client, profile is uploaded to the server
> - login the unix-box, change to the profile-share directory for the user and
> see that the directory-mode
>  for the 'shortcut'-directory is rwx for the owner and not r-x (directory
> mode in smb.conf is 770)
> - login on the client again with profile download, open 'network
> neighbourhood' and see that the
>  shortcut now is a 'normal directory' (dos read only not set) there is a
> file target in this directory which points
>  to the right place/the network share), set the dos-read-only attribute
> manualy with right-click properties
>  and see that the it act like a normal shortcut again.
> - log off and realize that the directory in the stored profile has mode rwx
> again instead of r-x
> Hope this points to a right solution, at least it's a little bug report for
> the described situation
> Greetings,
> Martin
> ----- Original Message -----
> From: "Gerald Carter" <gcarter at>
> To: "Oliver Heering" <Heering at>
> Cc: "Hitesh Talati" <htalati at>; <samba-ntdom at>
> Sent: Monday, May 07, 2001 3:15 PM
> Subject: Re: Re[2]: problem saving roaming profile
> > On Mon, 7 May 2001, Oliver Heering wrote:
> >
> > > Some guy in the samba-ntdom mailinglist said, this bug has been fixed
> > > in the CVS tree, but it actually hasn't. :( (i tried it out)
> >
> > Well technically, I can no longer reproduce it here. :-)
> > If those who are having problems will provide some extra details of their
> > environment (apologies if you have alreayd done this, but this is the
> > last message in this thread i can find in my inbox), we get it corrected.
> >
> >
> >
> >
> >
> >
> > Cheers, jerry
> > ----------------------------------------------------------------------
> >    /\  Gerald (Jerry) Carter                     Professional Services
> >  \/  VA Linux Systems   gcarter at
> >       SAMBA Team          jerry at
> >                     jerry at
> >
> >        "...a hundred billion castaways looking for a home."
> >                                 - Sting "Message in a Bottle" ( 1979 )
> >
> >
> >

Ing. Romy Perez Moreno
e-mail: romy at, romy at
tel: 5318 9067 /  5382-7157

More information about the samba-ntdom mailing list