(no subject)

kaab kaoutar kaab_k at hotmail.com
Sun May 6 12:17:35 GMT 2001

Hi !
I have a domain called EMAGIN, composed of NT workstations and an NT server 
called SERVER1.In one of the NT workstations, i have also installed linux 
mandrake7.2 in a partition. This machine is called kaoutar.

I've installed Samba in it, and tried to join the EMAGIN domain, letting 
SERVER1 the domain contoller. I have shared a directory called KTI.

Here is my smb.conf:
        netbios name=kaoutar
        workgroup = EMAGIN
        server string = Samba %v on (%h)
  security = domain
  password server=SERVER1
  encrypt passwords = Yes
local master = no
domain controller=SERVER1
name resolve order =lmhosts wins hosts bcast
mangled names = yes

        comment = KI
        path = /var/www/html/site_kti
        writeable = no
        guest ok = Yes
        read only =yes
I have created a user account in linux and samba with the same 
authentication parameters of the NT server administrator.

when i type : smbclient -U% -L LOCALHOST
I first got : unkonwn parameter encountered "domain controller"
then it gives the right results...

but i realized that it does not  make the right resolution for server1, so i 
added the ip address of server1 to the /etc/host file then it updated the 
error to:

and that's also what it gives when i tried to make samba server join the 
EMAGIN domain, so obviously samba have not yet joined the domain.

By the way the "/etc/lmhost" is composed of only one line: 
localhost !
is it normal ?

Well, the NT workstations and server easily access the shared directory!
However, when i try to browse the network via konquekor, it fails, it keeps 
asking for server1 and kaoutar authentication.

Get Your Private, Free E-mail from MSN Hotmail at http://www.hotmail.com.

More information about the samba-ntdom mailing list