hint: one possible reason for w2k not joining samba-controlled domain

Lars Grobe grobe at gmx.de
Sat May 5 17:07:25 GMT 2001


I had problems with win2k-workstations not being able to join my
samba-controlled domain. I don't know if there are others who made
the same error, but I think I should just report it, maybe it will
help someone. If not, just laugh about it ;-)

I had my samba configuration in 3 files: one "general" and two
for two servers. One of those was supposed to become the PDC.

Anybody who is familiar with samba will see the error, but I didn't
find it first and spent many hours there. It is necessary to define
everything that is necessary for domain-controlling in the default
smb.conf, not in any <servername>.smb.conf-files, which are a common
way to make multiple servers show up. With my configuration, the
PDC worked fine, but I couldn't get workstations become members of
the domain. So I put everything together into one smb.conf, voila!

(The extra <servername>.smb.conf is used when a client demands access
to <servername> - but the pdc is accessed with another name, so the
settings in <servername>.smb.conf are not read.

CU, Lars O. Grobe.

More information about the samba-ntdom mailing list