Infamous 'No mapping between account names and security ID's' message

HUTTEN Thomas thutten at
Mon Mar 19 16:37:30 GMT 2001

I recently got it to work

I'm not absolutely sure why it suddenly worked but here are the modifs i
did wich aparently made it work.

I changed the computer account entrys in /etc/passwd and /etc/smbpasswd
to uppercase.
I already had the user root in my smbpasswd but now i enabled it
(smbpasswd -e root).
Then i tried to join the domain with a W2k machine and again i
uppercased the computername before joining.

Then it worked.

Eric Pilger a écrit :
> Hear, hear! I recently tried for what must have been my 10th time.
> Rebuild from CVS, start with a fresh Win2K install, "simple" smb.conf, 5
> digit domain name, proper add user script, yada, yada, yada.
> Still got the same message about how I'm using a "computer account" and
> I should instead be using a "local or global user account". And then it
> adds an entry to the smbpasswd file for the machine, and disables it.
> What is this bloody "computer account" business? I have root in the
> smbpasswd file, and that's what I'm using.
> Boyd Kelly wrote:
> >  Hello all,+ the other Remote procedure calls, credentials conflit etc
> > messages.Yes I am having this same problem - spent most of the day on
> > it with no success.  Following instructions to the T. Recompining.
> > Have scanned all the posts about it, and don't seem to find any
> > logic.Some say it's after removing rpm's that things work.  Others its
> > the Wins server pointing to itself.  Odd/Even domain names? Yes root
> > was added to smbpasswd.  Followed the Howtos.  Tried deleting
> > accounts, recreating manually and let win2k do it.Does someone really
> > know what the issue is here?  Let's put this in a FAQ.  Thanks for
> > some more input.Boyd Kelly

- Tom -

More information about the samba-ntdom mailing list