Compile Differences

Greg J. Zartman, P.E. greg at
Thu Mar 15 21:49:21 GMT 2001

I posted a comment a little earlier today about an issue that I ran into
where the recent Samba2.2 CVS source was installing the samba executables in
different directories that I was used to.

After playing around with this a little, it appears that a CVS download that
I have from Feb 26th, 2001 compiles and installs much differently than a
download from today (3/15/01).

To compile, I have a very simple shell script with the command:
./configure --bindir=/usr/bin --sbindir=/usr/sbin --with-smbmount --with-pri
vatedir=/etc/private --libdir=/etc --localstatedir=/var/log --with-lockdir=/

When I run this script on the source from Feb 26th, I get an install that I
would expect.  The executables go in the /usr/bin directory and the smb.conf
file is located in the /etc directory.  If I run this script on the source
that I downloaded this morning, I get a very unexpected result.  It appears
that the configure routine is ignoring the command line parameters in my
script and compiling and installing using default type paths on a selection
of the executables.  For example, if I install using the compiled code from
today, the smbpasswd executable cannot find my smb.conf file (also turn for
smbclient, smbstatus, testparam).

Is there a new method that needs to be used to compile the samba source from

Thank you

Greg J. Zartman, P.E.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: Greg J. Zartman.vcf
Type: text/x-vcard
Size: 369 bytes
Desc: not available
Url :

More information about the samba-ntdom mailing list