Problems with pam_smb

Buchan Milne bgmilne at
Tue Jan 16 10:50:15 GMT 2001


I am trying to get authentication of our samba-pdc users by our imap
server (wu-imap). I have tried getting samba-appliance and samba-2.2.0
cvs to work using winbind, but had lots of problems.

I have now resorted to pam_smb. It compiled fine, and I am sure I have
all the right files in the right places, but have no idea whether it is
working or not. Using the debug option (which is supposed to log to
syslog) does nothing (which makes me wonder if pam_smb_auth is being
called at all).

I have read the pam-doc files, but must admit that I haven't done any
configuration of pam before.

Here is my /etc/pam_smb.conf
# cat /etc/pam_smb.conf 
(I don't know what the point of the 2nd entry is for a samba-based
domain currently anyway)

Here is my /etc/pam.d/imap:
# cat /etc/pam.d/imap 
#auth		required	/lib/security/ debug
auth		required	/lib/security/ shadow nullok
auth		required	/lib/security/ debug use_first_pass
account		required	/lib/security/

Originally, the file just had the first (uncommented) auth and the
account entry, but have tried the pam_smb_auth before and after the
pwdb, with various compinations of required and sufficient.

Running Linux Mandrake 7.1, samba 2.0.7, wu-imap 4.7b

This is the last thing I need to set up before I can get back to my real
work: my thesis !! (also, the last step before I migrate all our users
from the University's Netware server)

|----------------Registered Linux User #182071-----------------|
Buchan Milne                Mechanical Engineer, Network Manager
Cellphone * Work               +27 82 472 2231 * +27 21 808 2497
Stellenbosch Automotive Engineering

More information about the samba-ntdom mailing list