Printing from NT to Linux

Christian Barth barth at
Mon Apr 16 09:53:22 GMT 2001

> Hi,
>      I use RedHat 6.2 with samba-2.0.7.
>      When I tried to print from NT to Linux, I encountered the following
> problem.
>      I can print locally and from a remote Linux to my Linux server.
> But it says, "File, directory name or disk label usage fault" when I
> tried to print from NT to Linux.  A print queue has already been
> properly set up on Linux while the filter is left blank, which is tested
> ok locally.  A proper driver on NT is installed along with the process
> of printer setup wizard on NT through Network
> Neighbor.  And SAMBA works fine in terms of file sharing.
> The shared printer of Linux can be seen on NT as well.  There is no
> problem with the permissions regarding print queue cuz I've set
> /var/spool/lpd/lp2 as writable for user, group and other.  For your
> reference, the content of /etc/printcap is provided as below.
> lp2:\
>     :rw:sh:\
>     :lp=/dev/lp0:\
>     :sd=/var/spool/lpd/lp2:\
>     :fx=flp:
> /etc/smb.conf
> [epson]
>     path=/var/spool/lpd/lp2
>     printable=yes
>     printer=lp2
>     print command=lpr -b -P%p %s
>     lpq command=lpq -P%p
>     lprm command=lprm -P%p %j
>      Is there anything missing?
>     I'll really appreciate it if you can answer this question for me!
I never got that error message, but I would try 3 things first:
- create a seperate spool directory for samba, e.g. /var/spool/samba
  and set the permissions for it to drwxrwxrwt. Then take this
  directory as path in smb.conf, e.g. path=/var/spool/samba
- set the print/lpq/lprm command with the full path:
  print command = /usr/bin/lpr -b -P%p %s
- in smb.conf set "printing = bsd", or are you using lprng? I guess
  so, because of the -b in your lpr command, this case set printing =


In a world without walls and fences, who needs windows and gates? (SUN)

More information about the samba-ntdom mailing list