Logon Oddities

Mark Montazer mdmontazer at confluencewatersports.com
Mon Apr 9 15:08:28 GMT 2001

First off, I'd like to say thanks for all the great replies posted to this
group.  I've forgone posting up until now because of them.

Here's some information regarding my setup and configurations:
PDC: Samba 22a3
O/S: Linux Mandrake 7.2 / Kernel 2.2.17
Client(s): W2K PRO (Both are identical machines)
Problem: 1 machine is not reading the logon script.

I am currently testing samba's support of 2 W2K clients, and after a few
early problems, things appear to be running smooth, with one exception.  1
of the PC's can logon as expected (drives mapped properly), but the other
refuses to read the logon script and have its home directory mapped to
anything but Z:.  If I make a modification to the logon script, the first PC
picks-up the changes, but the second PC doesn't.  I'm not seeing any errors
in the logfiles coinciding with the times and dates of logons, so I'm a
little stumped.  I've checked the /etc/passwd for a machine name as well as
a username for both machines, but there appear to be no differences, except
the names of course.  I have also checked the
/usr/local/samba/private/smbpasswd as well with the same results.

My goal: To have drive H: on both machines mapped to its particular home
directory and drive I: on both machines mapped to a single shared folder.

Here is my current logon script (I've tried seperate logon scripts for each
user as well as symlinks to a master with no results):
net time \\SERVER /set /yes
@echo off

if %OS%.==Windows_NT. goto WinNT

net use j: \\SERVER\infosys
goto end

net use j: \\SSERVER\infosys /persistent:no


I have also specified that drive H: be my logon drive, while one
picks-it-up, the other doesn't.  I have specified that intentionally left
the logon path blank to prevent profiles from being written.  Here is my
config file:
        workgroup = TESTSERVER
        netbios name = SERVER
        server string = Confluence Watersports PDC
        encrypt passwords = Yes
        log file = /var/log/samba/log.%m
        time server = Yes
        domain admin group = @adm
        add user script = "/usr/sbin/adduser -n -g machines -c Machine -d
        logon script = scripts\%U.bat
        logon path =
        domain logons = Yes
        os level = 65
        guest account = ftp
        share modes = No
        logon drive = q:

        read only = No
        create mask = 0600
        directory mask = 0770
        map hidden = Yes
        browseable = No
        locking = No

        path = /usr/local/samba/netlogon
        map hidden = Yes
        browseable = No

        comment = Information Systems
        path = /export/infosys
        valid users = @infosys
        read only = No
        create mask = 0660
        directory mask = 0770
        map hidden = Yes
        browseable = No

        path = /usr/local/samba/printers
        write list = @adm
        guest ok = Yes

The only error reported by Samba is:
lib/util_sock.c:read_socket_data(479)  read_socket_data: recv failure for 4.
Error = Connection reset by peer

But this error was only reported once today a few hours ago, and I've tried
multiple logon configurations since.

Any and all help is appreciated.


More information about the samba-ntdom mailing list