In need of serious samba aid

Adegboyega S. I. Kassim adeka at
Thu Sep 28 19:13:44 GMT 2000

I've tried exhausting every way i know how to, but i cannot get my
samba-tng-alpha 2.6 to work. It compiles and installs fine, and i know
how t oset up shares fairly well ( i already have a runnig samba print
server in the office. - samba 2.07) The problem is i cannot seem to log
into the tng box. I've created as the PDC, but no matter what i try, i
get the following error:

[2000/09/28 14:42:43, 0] rpc_client/cli_lsarpc.c:lsa_open_secret(453)
[2000/09/28 14:42:43, 0] smbd/reply.c:reply_sesssetup_and_X(805)
  SMB LM/NT Password did not match!
[2000/09/28 14:42:43, 1] smbd/reply.c:reply_sesssetup_and_X(813)
  Rejecting user 'chrissa': authentication failed
[2000/09/28 14:42:43, 2] smbd/server.c:exit_server(448)

This is after i created the user 'chrissa' on the samba server box. Now,
below is my smb.conf file:

workgroup = CVRD
security = user
encrypt passwords = yes
netbios name = Zilla
server string = Samba %v on Zilla
lm announce = yes
#Browsing/Server options
domain logons = yes
os level = 65
dns proxy = yes
wins support = yes
preferred master = yes
local master = yes
time server = yes
domain master = yes
#Network configuration options
hosts allow = 10.0.0. localhost
interfaces =
bind interfaces only = yes
#Debug logging information
log level = 2
log file = /var/log/samba.log.%m
max log size = 50
debug timestamp = yes
load printers = yes
browsable = no
comment = Home Directory
writable = yes
map archive = yes
comment = PDC logon service
path = /export/samba/logon
public = no
browsable = no
writable = no
guest ok = no
path = /export/samba/profile
writable = yes
browsable = no
public = no

My train of thought , and small amount of experience first tells me the
user itself must be created on the box before attempting an smbpasswd
entry. That done, i make sure the passwords are the same for the box
itself as well as for smbpasswd. Now, i am unsure as to whether a trust
account must be created for w2k machines
i tried it without one and it did not work. I tried it WITH one, and it
did not create the account. I think i may have trouble loggingi n as
administrator using samedit:
 samedit -S Zilla -U Administrator -W CVRD
added interface ip= bcast= nmask=
added interface ip= bcast= nmask=
Enter Password:
Server: \\ZILLA:        User:   Administrator   Domain: CVRD
Connection:     failed session setup
cli_net_use_add: connection failed

i've tried using the password for root, i tried creating an
Administrator account on the box, editing both passwords, and trying
that, and it never worked either. Regardless, when i try samedit -S . -U
Administrator -W CVRD it works ok (though it takes any password i put
in). I tinkered with it for a LONg time yesterday and got one w2k
machine to log on, but for the life of me i cannot figure out how.
I have tried rebooting the windows machine many times, to no avail.

ANY help would be greatly appreciated!

More information about the samba-ntdom mailing list