Can't mount NT filesystem unless root

Buchan Milne bgmilne at
Mon Sep 11 15:21:42 GMT 2000

If users are going to smbmount, I think you need to set smbmnt and
smbumount as setuid root


Ho-Kuo Chan wrote:
> Hi,
>     I am trying to mount a directory on an NT Server on my Linux machine
> (Debian potato Linux kernel 2.2.17) using Samba. I have tried the
> following:
> smbmount //theServer/theDirectory /mnt/theDirectory -o
> username=myUsername workgroup=theWorkgroup.
> This works when I am logged in as root, but I can't mount as a user. I
> have also tried adding the follwing to fstab:
> //theServer/theDirectory /mnt/theDirectory
> defaults,ro,user,username=myUsername,workgroup=theWorkgroup,gid=100 0 0
> with no success. Is it possible to use smbmount as non-root? I have read
> the FAQ's and checked some of the archives with no success. Thanks for
> you help.

Buchan Milne                Mechanical Engineer, Network Manager
Cellphone                                           +27824722231
email                               mailto:bgmilne at
Centre for Automotive Engineering
South Africas first satellite:
Control Models                
|----------------Registered Linux User #182071-----------------|

More information about the samba-ntdom mailing list