Ross Davis ross at
Fri Sep 8 14:22:12 GMT 2000

Hi all,

Is SSL support broken in TNG2.6?  Has anybody tried TNG2.6 with
OpenLDAP2.0.1 (without SSL even)?
I compiled OpenLDAP agaist the latest version of OpenSSL as so:

env CPPFLAGS=-I"/usr/local/ssl/include/" LDFLAGS=-L"/usr/local/ssl/lib/"
./configure --prefix=/ --with-tls --enable-shared

Then I tried to compile SAMBA as so:

./configure --prefix=/ --with-ldap --with-ssl

But I get these errors:

checking configure summary
configure: error: summary failure. Aborting config

And these from my config.log:

configure:11454: gcc -o conftest -DHAVE_CRYPT_DECL
-I/usr/local/ssl/include -O -I/usr/local/etc/openldap/include/
-L/usr/local/ssl/lib -L/usr/local/etc/openldap/libraries/ conftest.c -lssl
-lcrypto -lreadline -lcurses  -ldl -lcrypt -lldap -llber 1>&5
/lib/ undefined reference to `res_query'
/lib/ undefined reference to `dn_expand'
collect2: ld returned 1 exit status
configure: failed program was:
#line 11450 "configure"
#include "confdefs.h"
#include "./tests/summary.c"

Any ideas?

More information about the samba-ntdom mailing list