Samba took over my NT domain - now I can't get it back.

greg.helwig at greg.helwig at
Tue Oct 10 01:13:25 GMT 2000

I am currently running samba 2.07 on Solaris X86 (5.7). Originally when I
started Samba in my NT environment, I set "prefered master = yes" and set the
browse election to 65. Eventually I ran into problems whereas my NT workstations
would/could not authenticate to my PDC. Since then, smb.conf has been changed to
read "prefered master = no" and ""os level = 0", but I am still having problems
with many more of my machines accross our NT domain.

Some of the oddities are...
...WINS database needs to be purged and rebuilt periodically.

...Our NetApp box loses its status as a NT server on the domain, rendering it
unusable - this needed to be readded in server manager several times and
eventually bounced.

...Two of our BDCs were randomly promoted to PDC. At one time we had 2 PDCs on
the domain at once. Our PDC lost its status and was demoted. The funny thing
about this is that at no time, other than the original master browser problem,
did any of our NT servers point a finger at our Samba server as the source of
the problem.

...Many of our workstations, accross the country, cannot authenticate against
the domain (PDC).

I have included the pertinent information from my smb.conf file. If anyone has
any ideas as to what I need to do to regain controll of my NT domain, please
reply to this message. I have tried all that I know how. Right now I have Samba
turned off to determine if the problems still exist.

Thanks in advance.....


           client code page = 437
           workgroup = ADA
           netbios name = LORE
           server string = Samba Server
           security = DOMAIN
           encrypt passwords = Yes
           allow trusted domains = No
           password server = nt_com
           log file = /opt/samba/var/log.%U
           max log size = 50
           name resolve order = host wins lmhosts bcast
           deadtime = 5
           socket options = TCP_NODELAY IPTOS_LOWDELAY
           load printers = No
           logon path =
           logon home =
           os level = 0
           lm announce = False
           lm interval = 0
           local master = No
           browse list = No
           dns proxy = No
           wins server =
           invalid users = root bin daemon adm sync shutdown halt mail newsuucp
operator gopher
           hosts allow = 149.154.

More information about the samba-ntdom mailing list