Rich Webb ntdom at
Sat May 6 05:36:04 GMT 2000

I guess that it is samba-tng that I want in order to do anything with domain
controller code.  I retrieved the cvs sources as was instructed, but I
cannot make it compile correctly.  I have read several messages on this list
pertaining to the error that I am having, and they all say to use smb.h from
yesterday.  I tried that as well, and it still doesn't work.  Also I'm
wondering if samba-2.1 is the same as samba-tng?  I have successfully
compiled 2.1 on my system, but every time I try to execute the binary, it
core dumps on me.

I am on Redhat 6.2 on a PII 350 with 256mb of ram.  The following is an
excerpt from the compile:

Using LIBS = -lreadline -lcurses  -ldl -lcrypt
Compiling rpc_client/cli_login.c with libtool
In file included from include/smb.h:1686,
                 from include/includes.h:651,
                 from rpc_client/cli_login.c:23:
include/rpc_creds.h:66: parse error before `NET_USER_INFO_3'
include/rpc_creds.h:66: warning: no semicolon at end of struct or union
include/rpc_creds.h:69: parse error before `}'
include/rpc_creds.h:69: warning: data definition has no type or storage
include/rpc_creds.h:73: parse error before `CREDS_HYBRID'

.... Content clipped ....

include/rpc_client_proto.h:38: warning: data definition has no type or
storage c
include/rpc_client_proto.h:711: parse error before `*'
include/rpc_client_proto.h:713: parse error before `*'
include/rpc_client_proto.h:718: parse error before `*'
include/rpc_client_proto.h:727: parse error before `*'
include/rpc_client_proto.h:730: parse error before `*'
rpc_client/cli_login.c: In function `cli_nt_setup_creds':
rpc_client/cli_login.c:105: storage size of `creds' isn't known
make: *** [rpc_client/cli_login.lo] Error 1

Lots and lots of parse errors in between these two sections.

Any help would be appreciated.

More information about the samba-ntdom mailing list