Problems with Samba-TNG PDC and W2k

Marcel Hoetter mh at
Fri Jun 30 11:54:23 GMT 2000

We are planning to replace almost all of out NT-servers with Linux-Samba
servers, including the PDC.
Clients will be W2k boxes and i want them to load their profiles and run
their login scripts from the PDC.
For test reasons i have set up a SambaTNG PDC for the domain TEST, a
machine account "testpc" and a  user
"testuser" I got as far as being able to log in and authentificatefrom
an w2k box and browse the shares on the server.
But though I did an  ./configure --with-profile  when compiling the
source and an chmod 1777 on the profile
directory, w2k gives me an error message telling me something like "no
permission to access the profile in
directory //SAMBAPDC/profile/username". Another problem is that the
(simpe) login script is not executed
and no drives are mapped. I wrote the script it in vi  and added ^M to
every line and i tried to write it in W2k and to
copy it in the right server directory. Nothing worked. I changed from
the samba-TNG-alpha-2.5.3 source to
the newest one via cvs, but the problems remained. I have already spend
a lot of time to find out what is wrong and
i would be glad for any help!

Here are parts of my smb.conf:

netbios name = SAMBAPDC
workgroup = TEST
log level = 5
log file = /var/lock/samba/log.%m
security = user
domain logons = yes
encrypt passwords = yes
os level = 65
domain master = yes
preferred master = yes
local master = yes
logon script = login.bat
logon drive = U:
logon home = \\SAMBAPDC\%U
logon path = \\SAMBAPDC\profile\%U

browseable = no
writable = yes
comment = Users' home directories

path = /opt/samba/netlogon
writable = no
guest ok = no
comment = PDC netlogon share

path = /opt/samba/profile
writeable = yes

path = /opt/samba/public
browseable = yes
public = yes
writeable = yes
comment = Public share

More information about the samba-ntdom mailing list