Latest CVS ...

Anthony Brock abrock at
Wed Jun 7 14:51:47 GMT 2000

Okay, I downloaded the latest CVS version of SAMBA_TNG monday, and found 
several things improved.  This is on a Sun Sparc running Solaris 2.7 (32-bit).

1) When attempting to add a new samba server to the domain, the password 
entry in the private/smbpasswd file actually shows a change!  This is the 
first time in months that samba appears to do anything to change the 
password for machines joining the domain.  Normally they return a message 
saying that everything worked, and then we see the following in the logs:

process_logon_packet: Logon from XXX.XXX.XXX.10: code = 0x12
process_logon_packet: Logon from XXX.XXX.XXX.10: code = 0x12
process_logon_packet: Logon from XXX.XXX.XXX.10: code = 0x7

Since this update, I am only seeing a single entry with code = 0x7

2) When comparing the smbpasswd file before and after adding a new NT 
Server to the domain, there are no differences.  The old behavior (which 
used to happen with samba servers as well) still happens (though the server 
is apparently able to open a connection according to the status page in SWAT).

3) We attempted to load exchange on a server using samba as the PDC, and it 
failed on Monday with a strange error "Windows NT Error <hex number>".

4)  All attempts to use User Manager for Domains have met with failure, 
either saying something about an invalid parameter or access is denied 
(though I am successfully logged in as DOMAIN\administrator).

5) Testing individual accounts using rpcclient succeeds as expected (using 
"ntlogin <username> <password>") but administrator now returns a failure.

6) Yesterday we updated against CVS again, and the exchange server 
installation failed the first time with the same error message as Monday, 
but then worked on a second attempt.  User Manager for Domains still does 
not even let me into the domain, and administrator is no longer able to 
directly access any shares on the PDC (I get prompted for a username and 
password).  Users CAN access resources on the PDC normally.  When adding 
users in Exchange, I get a message that the PDC is unavailable, but it 
properly displays the accounts from the PDC.  Otherwise, stuff appears to 
work decent.

7) Today, updated against CVS, and now Exchange will not let anyone in.  I 
am unable to add users in Exchange (it states that the domain cannot be 
contacted).  Also, I am unable to login at the NT server's console as any 
user other than administrator.

Let me know if you need more detail/logs.

* Anthony Brock                                         abrock at *
* Director of Network Services                         George Fox University *

More information about the samba-ntdom mailing list