Username map problem!

Makis Marmaridis I.Marmaridis at
Tue Jul 25 23:50:45 GMT 2000

Hi all,

I am setting up a server as a domain controller serving 7 clients (NT 4.0
workstation). The server runs RedHat linux 6.0 with the latest kernel and
Samba_TNG_Alpha_2.5. Although I thought I had everything working fine, when
I tried to logon to the domain as one of the users the logon attempt failed
(I got the message about incorrect username or password in NT). I checked
the logs and the following error message showed up:

"[2000/07/26 04:10:00, 0] lib/username.c:map_username(87)
  can't open username map /etc/samba/"

I have tried giving 777 permissions to the mapping file but still nothing
I ever compiled and installed samba 2.07 instead but the same problem

The relevant line of my smb.conf is below:

username map = /etc/samba/

An extract of the file is below:


99580793 = s9580793
99580807 = s9580807
99580810 = s9580810
99580823 = s9580823
99580966 = s9580966
99581464 = s9581464
99582366 = s9582366
99584069 = s9584069
99584610 = s9584610


* the username to the right is the unix one. Users will be using the one to
the left to logon.
each unix username has an account created in smbpasswd.

Except for this problem where it seems that Samba cannot map a username to
its corresponding unix username, logons work beautifully!

Also, in the samba log file (samba.log.smb), I noticed entries about
(haven't got the exact wording) : requested 10000 files 10401 available. But
that only looked like a warning and not an error.

I would appreciate any help as it is critical that I get the server in
production as soon as possible. (Sorry for the size of the email!)

Thank you in advance,

More information about the samba-ntdom mailing list