password with special chars

Osama Abu-Aish osabmt00 at
Thu Apr 27 23:27:38 GMT 2000

hi out there,

I tried to join a TNG-WKS to an NT4SP5 controlled Domain. Thereby I
found some strange behaivor of smbpasswd:

first: smbpasswd -a root
-> entered passwd containing a number, let's say abcde1fg
-> User root added blablablabla, everything looks fine.

When trying to join the domain with rpcclient or samedit:
use \\samba-wks -Uroot%abcde1fg -Wsamba-wks

Connection:     error connecting to (Connection refused)
failed session setup
cli_net_use_add: connection failed

then I - just for fun - tried without the "1":
use \\samba-wks -Uroot%abcdefg -Wsamba-wks

Connection:     error connecting to (Connection refused)
session setup ok
Domain=[NT-DOMAIN] OS=[Unix] Server=[Samba TNG-alpha]

Then I su'ed to another user and tried
smbpasswd -U root -r
old: abcde1fg
new: something
new: something

error connecting to (Connection refused)
machine rejected the password change: Error was : The specified password is 
Failed to change password for root

again without "1"

Password changed for user root

then I did the following:
smbpasswd -U root -r (note that the account exists in smbpasswd now)
old: valid passwd
new: abcde1fg
new: abcde1fg

Password changed for user root

and from now on abcde1fg is correctly accepted as password.

What does this mean?

Greetings, Osama
Fachhochschule für Technik Esslingen
Außenstelle Goeppingen

More information about the samba-ntdom mailing list