[Fwd: Problems with 2.4.2 - msrpc redirect failed]

Phil Mayers p.mayers at ic.ac.uk
Sat Apr 22 23:49:31 GMT 2000

I didn't truncate the log - it must have been samba.

I think it would be incorrect to say *any* RPC stuff worked. The
offending bit of code is in smbd, and all RPC-related functions fail.

For example: double clicking on the server in Network Neighbourhood
returns a "the server service is not started" error, but mapping drives
directly works.

However - the suggested fix worked. Thanks a lot!


Elrond wrote:
> I checked a little around for all this reuse-stuff, it's
> more Lukes stuff, but it looks like reuse should be False,
> so, please try this:
> In rpc_server/srv_pipe_hnd.c, round line 126:
> Replace:
>         m = ncalrpc_l_use_add(pipe_name, key, True, &is_new);
> with:
>         m = ncalrpc_l_use_add(pipe_name, key, False, &is_new);
> I'm not going to change this in CVS, cause I don't know
> enough about the reuse-stuff. So if this helps, it would be
> nice, if you could inform Luke and me, so we/I can fix
> this.

More information about the samba-ntdom mailing list