Problem compiling SAMBA with ldap support

Adam Williams awilliam at
Fri Sep 17 10:24:59 GMT 1999

> > checking for four-argument statfs (AIX-3.2.5, SVR3)... no
> > checking for two-argument statfs with statfs.fsize member (4.4BSD and
> > NetBSD)... no
> > checking for two-argument statfs with struct fs_data (Ultrix)... no
> > checking configure summarty
> > configure: error: summary failure. Aborting config
> Looks strange and I had it too. Leave ldap out and this works.
> Installing bind-devel solved this for me.

I have now tried in on three diffrent RH6.0 and a RH5.0 box and it will
configure on none of them.  It dies with the same error message every time.  I
have checked that I have bind-devel installed on all machines.  At first I
though out of the blue it might be that the first machine uses nss_ldap so I
tried one with only an /etc/passwd file and one that uses NIS, and it breaks on
them all (course I don't know why I thought that might be a problem).  All
three machines compile other applications,  including ones that use LDAP,
without complaint.  LDAP is OpenLDAP 1.2.3 and OpenLDAP 1.2.6, from the RPM's.

More information about the samba-ntdom mailing list