Compiling problems HEAD-CVS linux-RH-5.2 kernel-2.2.10

Laurent Menu at
Thu Oct 14 11:16:26 GMT 1999

jrb at wrote:
> Yeah, me too. It happens on Suse6.2 and Solaris2.7as well. I tried
> --without-ldap, but the same error occurs and nmbd can't be linked.
> CVS is from today.
> Juergen
> > A few days ago someone sent a similar question compiling with-ldap. I
> > have the same problem with:
> > /configure  --prefix=/usr/local/etc/samba
> > /configure --with-quotas --prefix=/usr/local/etc/samba --with-ldap
> >
> >
> > I tried with the CVS-HEAD (991009 and 991014), and the make says:
> > ..
> > libsmb/clientgen.o: In function `cli_establish_connection':
> > libsmb/clientgen.o(.text+0x4fa4): undefined reference to `prs_init'
> > libsmb/clientgen.o(.text+0x4ffd): undefined reference to
> > `create_ntlmssp_resp'
> > libsmb/clientgen.o(.text+0x5007): undefined reference to `prs_link'
> > libsmb/clientgen.o(.text+0x50af): undefined reference to `prs_mem_free'
> > make: *** [bin/nmbd] Error 1

I've had that one too.
I modified the Makefile and added

to the following make variables

'make' is then OK on a linux mandrake 6.0

as Makefile is generated by ./configure (please confirm), does it come
from some missing parameters to ./configure or is something wrong with
the Makefile template ( ?) ? Duhhhh.

Just to be sure : I get the source with the commands described in the
  cvs -d :pserver:cvs at login 
  cvs -d :pserver:cvs at co samba
and then
  cvs update -d -P 
to update the directory

Are they the correct commands to get the bleeding edge samba with NTDOM
or am I missing something ?

Laurent Menu

More information about the samba-ntdom mailing list