SAMBA 2.0 and SP5

Al Margolis al at
Mon Oct 11 13:48:19 GMT 1999

FYI for people working on this problem:

I have a very similar situation at one of my client's networks and recently 
solved it with this same LMHOSTS solution.  The kicker is that in my case 
that all the domain controllers are real M$ NT Servers.  We have been 
making lots of changes to our network so I am not yet certain what caused 
the problem, but my best guess is that it started when we went to multiple 
WINS servers.

This does not seem to be much of a problem for computers that have been up 
and running for a while (generally NT Workstation SP3) but we were unable 
to add new computers to the network (generally NT Workstation SP4) due to 
the "could not locate domain controller" preventing us from joining the 
domain.  We have had some reports of people having this kind of problem 
after coming back from vacation, but I haven't been able to confirm that -- 
this could imply some kind of WINS reservation expiration problem.

I have only limited access to this network, but would be willing to do 
whatever testing / reporting I can if it will help SAMBA PDC development.

Al Margolis       al at
The Software Engineering Store
650-952-7672       FAX: -7629

-----Original Message-----
From: Dave.Stevenson at [mailto:Dave.Stevenson at]
Sent: Monday, October 11, 1999 3:14 AM
To: Multiple recipients of list SAMBA-NTDOM
Subject: Re: SAMBA 2.0 and SP5

Some progress

 2.1pre-alpha 10-9-99 NT4 clients SP3,4,5


 Roaming profiles becoming "corrupted" ( eg Desktop settings, program 
settings going astray)
 or "Using cached profile" type messages

 "Could not locate domain controller for domain XXXXX" (XXXX=local domain, 
single subnet) so
 logins failing.

 I am running WINS, I did not use local LMHOSTS files

 It seems putting an entry in client LMHOSTS file for the PDC works a 
little wonder  mypdchost  #PRE #DOM:mydomain  "mypdchost      \0x1b"  #PRE   (carefull with the spaces 

 seems to improve the situation considerably. No longer get the "could not 
locate domain controller"
 messages, though it is early days to say that the problem has definitely 
worked around.

 My Samba PDC= my WINS server = logon server  so it takes quite a hit at 

 My guess (and it is only a guess) is that the name resolution request( 
h-node type?) (for the PDC?)
at logon was timing out. I thought that the fallback was to broadcast, 
which should have been
OK (all on same subnet).

If I've got #PREloaded LMHOSTS entries anyone know if WINS is still called 
first for those entries?
(would seem unnessary) Is not clear to me from Resource Kit book.

Also, "Using cached profile" has disappeared on the machines I changed to 
though this was rather intermittant so needs watching for longer.

More information about the samba-ntdom mailing list