file problem with samba2.4b and sun 2.6(sparc)

Todd B. Blake tblake at
Tue Jul 20 19:28:51 GMT 1999

We currently have an NT domain, and samba version 2.0.4b authenticating off of it
using security=server and password server = gold.  It seems whenever someone
changes their password from a 95/98 client on the NT domain, and then tried to
access the samba server, the samba server is passing an incorrect password to the
NT server, and thereby not allowing the user to access the samba shares.  If the
user changes their password and reboots, however, they can access the shares
without a problem.  I've tried security=domain as well and added myself to the
domain, and that didn't work at all.  Any clues?

P.S.  If the user is running NT, there is no problem.

Giulio Orsero wrote:

> On Wed, 21 Jul 1999 04:48:54 +1000, hai scritto:
> >we found the problem. it has to do with the locking system. we changed
> >the smb.conf to locking = false and deleted the lockfile
> >(/var/adm/STATUS..LCK) and now everything works. But why we do have the
> >XXX locking problem?
> It's very dangerous to disable locking on a not-read-only fs (what you did is
> ok for cdroms and the like).
> Post the log of smbd while you have troubles (reenable locking), so someone of
> the samba team can see and tell you what's wrong.
> --
> giulioo at

Todd Blake
tblake at
TU Computing and Network Services
Home Page -

More information about the samba-ntdom mailing list