amrestore of a pc with smbclient

Andy Smith abs at
Fri Jan 29 18:11:57 GMT 1999


I've been having a discussion over in the amanda user group about this
problem, it would appear that smbclient is failing to read correctly
from stdin (in this case a pipe from amrestore).  This smbclient is the
latest cvs version from the head branch, I haven't tried it yet with
the 2.0.0 release, so I haven't at this stage reported it to samba-bugs.
I have only just started using amanda, so cant confirm that it worked
before (in our environment).  Can anyone spot anything I might be doing
wrong, or suggest any other tests I can carry out?


-----Forwarded message from Andy Smith <abs at>-----

From: Andy Smith <abs at>
To: Amanda Users List <amanda-users at>
Subject: Re: amrestore of a pc with smbclient

Sorry to say, I cant get anything back from the tape using amrecover,
I still get the message 'checksums don't match ...'

However, I am pleased to say that :-

amrestore -p /dev/rmt/0cbn localhost '//d3023/c' | gnutar xvf - ./TEMP/test.reg

works, as does :-

amrestore /dev/rmt/0cbn localhost '//d3023/c'
smbclient '//d3023/c$' 'XXXXXX' -N -U administrator -W d3023 -d0
          -Tx localhost.__d3023_c\$.19990129.0 './TEMP/d3023.reg'

(NB, the smbclient arguments came from amrecover.debug)

and of course :-

amrestore -p /dev/rmt/0cbn localhost '//d3023/c' | 
          smbclient '//d3023/c$' 'XXXXXX' -N -U administrator -W d3023 -d0
          -Tx - './TEMP/d3023.reg'

generates an error, this went to stdout :-

Added interface ip= bcast= nmask=
checksums don't match 0 59898
abandoning restore, -1 from read tar header

and this went to stderr :-

amrestore:   0: skipping start of tape: date 19990129 label MITU-Backup-2
amrestore:   1: skipping localhost._.19990129.1
amrestore:   2: restoring localhost.__d3023_c$.19990129.0
Error 32 (Broken pipe) offset 32768+32768, wrote 144304
amrestore: pipe reader has quit in middle of file.
amrestore: skipping ahead to start of next file, please wait...

So do I presume my smbclient (2.1.0-prealpha if you recall) is behaving
differently than others, and I should be asking in samba-ntdom?

-----End of forwarded message-----

  _          __         Maunsell Ltd, IT Unit    Tel  : 0181-663-6565
 /_|   _/   (  _  '_//  160 Croydon Road,        Fax  : 0181-663-6723
(  |/)(/(/ __)//)/ //)  Beckenham, Kent BR3 4DE  Email: abs at
        /               England.                 -or- abs at

More information about the samba-ntdom mailing list