Samba 2.0 PDC problems with Solaris

valankar at valankar at
Sat Jan 23 00:23:05 GMT 1999

Hello, we are experiencing some strange problems with PDC support in 
Samba 2.0 release. Our server is a Sun box running Solaris 2.5. There are
about 20 NT 4 (SP3) workstations running as clients. Samba was compiled
with gcc.

Originally we had deployed an alpha version of Samba 1.9.x being a PDC of
the machines. Everything worked well. I had decided to upgrade to the
2.0 release, and when I did, strange problems occurred. Please note that
when I did upgrade, I did not use any of the configuration/smbpasswd files
of the old setup. I basically started from scratch, doing a similar
configuration to what I had used before.

First, using 2.0 release, I would invariably get Application Error dialogs
once the user logged in, with errors such as 'the memory referenced by
0x0000003d could not be opened for "read"' or something similar. Many
applications failed to even start. What I then did was removed the 'profile'
directory of the user that had been created when I was running the Samba
1.9.x alpha version. This basically fixed the problem, all except for
one specific program, KIX32.EXE (the Kixstart scripting program). This
program would crash with the memory reference error (with an address of
0x0000000, like a null pointer dereference). All other applications worked
fine. Please note that when I logon as administrator on the local machine,
the program runs fine. Also if I create a local user account and run the
program as that user, it works fine.

I wanted to pinpoint whether this was being caused by Samba, so what I then
did was move back to my old 1.9.x alpha version which I still had, and
then the KIX32.EXE application, as well as all others, worked fine. Please
note that when I made this switch (and all other future ones) I did remove
the user's profile directory (on the local machine, and roaming as well) in
order to start with a clean user. I had also did a double-check to make
sure the error was reproducible from scratch in Samba 2.0 release, which 
it was.

We had a need for this KIX32 application, so I decided to try the latest
CVS source of samba. I did so today, and the application worked! This led
me to believe there was some problem in the Samba 2.0 release. All was going
well with the CVS release but then I noticed another problem. I could not
access a shared printer that was shared on another NT workstation
(which was within the same domain). NT's error was the Network path could
not be found. This share is available to 'Everyone' with Full Control.

At this point, I went back to the 1.9.x alpha release and to my surprise
everything worked. I could run the KIX32 application, as well as access the
shared printer. So, I'm forced to continue using this version. I have no
idea what could be causing this problem, and would appreciate any help.
This alpha version that I'm using is indeed very old. Unfortunately, it
is the only version that is working for us. Thanks.


More information about the samba-ntdom mailing list