Samba as a PDC and file permissions - Odd behaviour.

John Williams williamj at
Thu Jan 21 15:39:21 GMT 1999

I set up a Samba 2 PDC and created a machine account, then set up a new
NT4/SP3 client.  When I was asked to configure networking I added it to the
domain, everything went fine.  After the normal reboots I could login to
the domain and could access my home directory etc.  However I noticed that
"EVERYONE" had full control of the NTFS partition i.e. there was no
security.  I logged in as administrator and tried to change it using
FIXACLS from the resource kit but it failed to work.  I then selected
Explorer and went to permissions and tried to change them but explorer
crashed with the error message:
	Exception access violation 0xc0000005
	Address 0x778933aa

I unplugged the workstation from the LAN and logged in as administrator,
changes the ACLs, reconnected to the network and everything is fine.

Is this behaviour caused by some feature of the Samba PDC?  When I've set
up NT systems before, they've always come up with rational permissions.  I
always convert to NTFS during installation, I know running convert later
dows leave you with open file ACLs.
John Williams				Team Leader Academic Systems
LIS (MB)				Aston University
Aston Triangle				Birmingham B4 7ET
0121 359 3611 x 5142			Fax 0121 359 7358
Mobile 07801266235

More information about the samba-ntdom mailing list