Problem with WinNT SP6 after Joining Samba Domain

Norman Weathers norman at
Fri Dec 3 14:45:30 GMT 1999

Gary Terpstra wrote:

> I am having a problem with WinNT SP6 after joining Samba Domain.  I am
> able to join the domain successfully.  After I join the domain, I am
> not able to assign rights from the domain to the WinNT machine.  When
> I go to User Manager and try to add an individual or group from the
> domain I get this message "Unable to browse the selected domain
> because the following error occurred: The tag is invalid."  Can anyone
> provide any help.  Thanks
> Gary Terpstra
> 423-842-7501
> glterp at

I am having the same problem with a SP6 machine.  Of course, we just
migrated machines
recently, too (moved our Domain from an older PII 266 to a newer dual
PIII 550.  Works
great guys!).  I was wondering, when I moved the domain information from
one system to
another, I copied over all of the information (smb.conf, smbpasswd,
passwd), and I also
copied the MACHINE.SID.  Now, all systems can still log in and are
authenticated by the
samba PDC (v2.0.6), but the other tech coordinator and myself had
ourselves added to the
individual computers as users with administrative rights.  This no
longer works real well.
Should I not have copied the MACHINE.SID file?  Is there anyway to
create domain admin
group with 2.0.6 (last I had read, the Domain admin and group files
where only good for
2.1, I thought?)?

Also, we use Publisher on our NT Workstations.  Recently, someone had
moved her stuff
to her home directory, including all of her publisher files.  When she
tried to open and edit
the file, it worked, but when she tried to save the file, Publisher
reported an error stating
that the disk is full or write protected, or that there is insufficient
memory to perform the
action.  Well, we tried saving on the server and to her local machine,
and neither way did
it work.  Finally, after losing all of her changes, I had her copy the
file to the local machine
and work on it there, upon which it opened, editted, and saved fine.
Before, it also seemed
to have corrupted her working copy (within Publisher) whenever she was
working on
it from the server.  Has anyone else noticed this?  This is Publisher 98
that caused the

I know this is long, but if anyone could point me into a right
direction, I would greatly
appreciate it.


Norman Weathers
Technology Coordinator ETS
University of Arkansas, Fayetteville

phone: (501) 575-3553 or (501) 575-4344
email: nweathe at or norman at

"It's not that I 'prefer' to do this without an NT server.... I
just 'prefer' to do it where it will work..."

More information about the samba-ntdom mailing list