Password change using Samba PDC

Kevin Colby kevinc at
Mon Apr 5 14:36:33 GMT 1999

We're using the latest CVS source and are having trouble getting
clients to be able to change their password.

Problem #1 is that Win95 clients can't seem to even find the
Samba PDC when they execute a password change via the control
panel's "MS Networking" password change.  I've tried watching
the Samba PDC for any inkling of a response.  It never gets
their call, so to speak.  Any ideas on what is going wrong
there?  (I doubt it is a Samba issue.)

Attempting to bypass problem 1 for the moment, we have tried
issueing the password change from the dos shell in 95
("net password /domain:SAMBADOM myusername").  This _does_
contact the Samba PDC, but Samba complains that the old
password is incorrect.  The exact failure occurs in
smbd/chgpasswd.c, and indeed, the hashes it is comparing are
different (it does a memcmp).

Are we missing some obvious setting, or is this a real problem?

Interestingly enough, smbpasswd as root works fine (users can
then login to the domain), but smbpasswd as the user fails
to correctly verify their old SMB password.  Of course, this
code is elsewhere.  Is this related?

Any ideas would be most welcome.
We are trying very hard here to get a Samba PDC working,
with the eventual plan to switch over perhaps a dozen NT servers.

	- Kevin Colby
	  kevinc at

More information about the samba-ntdom mailing list