UIDs x GIDs on Samba-NTdom

Celso Kopp Webber webber at sj.univali.rct-sc.br
Thu Apr 1 03:07:01 GMT 1999

	Hi all!

	I've found a "feature" on Samba yesterday that may interest you.
Sorry if this is already known, or if it was already discussed here
(although I haven't seen anything lately).

	I had one system with one user with UID #300, named User1, and one
group with GID #300, named Laboratory.

	Whenever I tried on an NT client add permissions to group
Laboratory, after I select it on the list, NT showed in fact permissions to
user User1. It came to my mind that the coincidence beetween one's UID and
the other's GID was the cause. Changing GID for Laboratory solved the

	I'm having also another problem. Since I'm using RedHat on the
server side, every user has its own primary group, for instance, bob's
primary group is bob. Both bob UID and bob GID are the same. This causes
UsrMgr.exe and others to not show the list of groups/users, because if I
have 700 users, I have at least 700 groups.

	Is there any way of using options like "domain group map = " to
filter some groups, i.e., not showing some of them.

	Thanks for your help in advance, and congratulations for the great
software samba is!

Prof. Celso Kopp Webber

Universidade do Vale do Itajai' - UNIVALI
Campus Sao Jose - Sao Jose, SC
Administracao de Redes
Rod. SC 407, Km. 4
88122-000                     Sao Jose-SC

Fone: +55 (48) 281-1505
Fax:  +55 (48) 281-1506

More information about the samba-ntdom mailing list