compiling cvs source from 10/21/1998 10:30 -6 GMT

Sean Mathews mathewss at
Wed Oct 21 19:52:32 GMT 1998

 Seems no one saw my messages i sent a week ago about
problems with compiling the file.
I posted the problem with my fix and seems everyone
ignored it.. I just did a cvs now and the same problem
occures.. maybe it is related to your problem also Matthew.

My compiler hickups as follows.

Compiling lib/crc32.c with -fpic
Linking shared library bin/
ld: No reference to __DYNAMIC
make: *** [bin/] Error 1  

 I will have to go diggin now back through the
samba email archive to find my fix again and re apply it.

 Ok here is what i did to fix my problem in the Makefile

bin/ $(PICOBJS)
        @echo Linking shared library $@
        @$(LD) -shared -Bshareable -o $@ $(PICOBJS) $(LIBS)

i added -Bshareable                                         

anyway not sure if this will help but i sure hope someone
looks into this as its not somthing i want to patch every time :c)

  Sean Mathews

On Thu, 22 Oct 1998, Matthew Jamison wrote:

> I am having a problem compiling the latest cvs code.  I have compiled the
> cvs before but it was a few months ago when you still had to change the
> makefile.  I run the configure file in the source directory and it does
> create a makefile.  I run make and it kill over with the error message
> Linking shared library bin/
> ld: invalid number `-o'
> *** Error code 1
> make: Fatal error: Command Failed for target `bin/'
> I am using gcc on a Solaris 2.5.1 box.  Could some one tell me what is go
> wrong?
> Matthew

More information about the samba-ntdom mailing list