problem with samba on a NT domain

Remy Bruno suprem at
Fri Oct 16 12:50:43 GMT 1998

I can't make my samba work properly on a NT domain.
In my engineering school, all computers are on a NT domain served by the
machine "REZO". Everyone has an account name and a password stored on
this machine. A people (say A) can allow another people (say B) to read
or write data on his own computer by sharing a directory for him. When B
logs in on his own computer by begining a windows session, he is
authentified by REZO (he enters his login and password). Then he can
read and write on A's computer with the "network neighbourhood". All
this works fine between 2 windows, but with my Linux, I can't read and
write on shares other make for me. The other can access the shares I
make to them if they have an account on my machine by using the login
and password of their account, but not with the login/password of REZO.
I can connect on another samba (using the login/passwd of the
corresponding linux). I've tried many configurations, I read
documentation, but it doesn't work. What most bothers me is the fact
that I can't log on a window machine (the fact that people must enter
their password of my machine to log in is not really a problem: I'm sure
that only people I allow to log in can log in, whereas REZO would say if
people can log in on my machine if this worked).
When I try to connect on a Window computer with smbclient, it says
"FINDFIRST gave ERRDOS - ERRnoaccess (Acess denied.)" when I try to make
ls, whereas I sould have access to the share (I provide the login/passwd
of REZO). smbmount says "smb_dont_catch_keepalive: server->data_ready ==
I'd be happy and gratefull if someone could help me.

Student at Supelec
e-mail: suprem at

More information about the samba-ntdom mailing list