NT Logins no longer functioning.

John Lundbäck e92_jlu at e.kth.se
Mon Oct 12 19:14:41 GMT 1998

> I downloaded the latest/bloodiest this morning and decided to move some
> things around.  In the process, I blew away the prior version.  I have now
> gotten samba to appear to be up functioning again.  However, when I try to
> login through my NT workstation.  It claims that the password is not
> correct.  I have used the smbclient that comes with Samba, and it works just
> fine.  Any ideas?  Thanks in advance.  Also, output from my testparm is
> attached below.

Well, for me I compiled alpha-9 and tested it and found it blew right out into
the blue sky. However during the testing of this version I added some computers
using the smbpasswd -a -m machine$ command. When I later switched back to 
alpha-7 version which worked, I found out that all the computers I added with
the newer version of smbpasswd could not access any other computer on the LAN
as samba complained that the password was incorrect. The solution which worked
for me was to remove all the entries in the smbpasswd file and redo the 
smbpasswd -a -m foo$ command. After which all my computers lived happily
together on the LAN.

Regards, John

More information about the samba-ntdom mailing list