More on my problems

Don Badrak dbadrak at
Fri Nov 27 15:24:39 GMT 1998


On Sat, 28 Nov 1998, Dejan Ilic wrote:

> Tried both CVS-distributions (Beta-1 & Beta-2) and both show the same
> problem om my Solaris_x86 2.6
> Linking bin/smbd
> Undefined                       first referenced
>  symbol                             in file
> __inet_addr                         libsmb/namequery.o
> __inet_ntoa                         libsmb/clientgen.o
> ld: fatal: Symbol referencing errors. No output written to bin/smbd
> inet_ntoa exitst in libnsl, but not "__inet_ntoa".
> sambe for __inet_addr. I have not had the problems earlier, but I
> haven't compiled the newest releases for a couple day either :-)
> It worked fine some weeks ago. At least 98-11-12 release works.

Those symbols are from the bind 8.1.2 library.  Make sure that somewhere
you have -lbind in your link line (you may also need a

Do "nm /location/of/bind/libary/libbind.a | grep __inet" to see that you
get the right library.

Bind 4.9.x used libresolv.a and lib44bsd.a (compatability library).  in
Bind 8.x, it is all rolled into libbind.a.

Don Badrak <dbadrak at>              301.457.1793 work
Telecommunications Office		     301.457.4438 fax
U.S. Bureau of the Census                    301.457.1828 fax
Suitland MD, USA

More information about the samba-ntdom mailing list