Long machine names...

Tim Winders twinders at SPC.cc.tx.us
Thu May 21 17:30:33 GMT 1998

On Thu, 21 May 1998, Jeremy Allison wrote:

> Tim Winders wrote:
> > 
> > I just ran into a "problem" with the machine accounts requiring an entry
> > in the /etc/passwd file for account creating.  On *MY* system, unix
> > account names can only be 8 characters.  I have (had) an NT machine with
> > the name SUPPORT2 (8 character) but to create the unix account, I needed 9
> > characters (SUPPORT2$) which wouldn't work.  I created the account as
> > SUPPORT2 and changed the entry to SUPPORT2$ and then ran smbpasswd -a -m
> > support2 support2 but the NT machine said it could login because the
> > account in the domain didn't exist or the password didn't match.  I ended
> > up changing the machine name to SUP2 and adding the appropriate entries
> > and this worked...
> >
> As a matter of interest, which UNIX is this ?

Digital Unix 4.0D

> > Hey!  Wait a minute... now that I look again at my /etc/passwd file, there
> > are NO machine entries there... does smbpasswd REMOVE the entries from
> > /etc/passwd when the machine account is created?
> > 
> No - smbpasswd never touches the /etc/passwd file.

OK, now I am VERY confused.  I ran the unix adduser utility and added the
new user called sup2$ (the new name of my machine).  I verified the entry
WAS in /etc/passwd.  I then IMMEDIATELY ran smbpasswd -a -m sup2 sup2 and
the samba private/smbpasswd file was updated to relfect the new sup2$
machine account.  I could then login with the NT box.  I then checked the
/etc/passwd file and there were NO machine account entries...

=== Tim

|  Tim Winders, CNE, MCSE        |  Email:  TWinders at SPC.cc.tx.us   |
|  Network Administrator         |  Phone:  806-894-9611 x 2369     |
|  South Plains College          |  Fax:    806-897-4711            |

More information about the samba-ntdom mailing list