Problems doing update

Tavis Barr tavis at
Tue May 12 03:10:30 GMT 1998

I am re-posting a question to the list at someone's suggestion.  The 
problem is this: I _think_ I am using the latest CVS update of the code 
as of this afternoon.  However, there are some things about the code 
that appear old:

(1) When I run smbclient, I get a header that says

 Domain=[SAMBADC] OS=[Unix] Server=[Samba 1.9.18p3]

(2) smbclient crashes when run against a remote server, stating for example:

Connecting to at port 139
error connecting to (Connection refused)
cli_establish_connection: failed to connect to MARKOV<00> (
client_init: connection failed
warning: connection could not be established to<20>
this version of smbclient may crash if you proceed
~ %

(3) log.nmbd indicates that nmbd is version 1.9.18p3 and doesn't recognize 
the parameter "domain sid"

Nevertheless, the code is clearly new in some respects.  testparm 
recognizes "domain sid" and the binary swat is installed as well.  

When I put this query in a few days ago, I got a bunch of responses 
saying "you need to update your code."  So I did it _again_.  I did this 
by typing (from the directory smb above the samba directory:

smb % mv samba samba-old
smb % cvs -d :pserver:cvs at login 
[enter password cvs]
smb % cvs -d :pserver:cvs at co samba 
[lots of output, in the form of "Updating..."]
smb % cd samba
samba % cvs update -d -P -A
[lots more similar output]
samba % cd source
[edit Makefile for SunOS 4 flags and CC=gcc and my domain]
samba % make
[compiling output]
samba % make install

I then restart Samba.  Am I missing something really basic?  I ran it by 
Luke and he thought it looked okay and might be something in my smb.conf 
file.  I'm enclosing that below.  I would strongly welcome any suggestions 
anyone has.


; Configuration file for smbd.
; ============================================================================

   server string=Sparc2 in Sociology

   hosts allow = , 128.59. , 127.
   guest account = nobody
   socket options = TCP_NODELAY 
   domain sid = S-1-5-21-059-226-071
   domain logons = yes
   domain master = yes
   local master = yes
   os level = 100
   security = domain
   encrypt passwords = no
   logon script = %U.bat
   logon drive = l:

   wins support = yes
   wins proxy = yes
   remote announce = ,,,
   remote browse sync =
   preferred master = yes

   printing = bsd
   printcap name = /etc/printcap
   load printers = yes

   log file = /usr/local/samba/log.%m
   debug level = 3

   lock directory = /usr/local/samba/var/locks
   share modes = yes

   path = /usr/local/samba/lib/netlogon
   writeable = no
   guest ok = yes
   share modes = no
   public = yes

   comment = Home Directories
   read only = no
   create mode = 0750

   comment = All Printers
   printable = yes
   public = no
   writable = no
   create mode = 0700

More information about the samba-ntdom mailing list